Bugs in form validation

Tagged: 

This topic contains 19 replies, has 2 voices, and was last updated by  Supporter 2 years, 11 months ago.

Viewing 20 posts - 1 through 20 (of 20 total)
  • Author
    Posts
  • #2892

    ondrej
    Participant

    Unknow

    Hello folks,
    you have some small bugs in validating forms for contact and register modules. How to reproduce (even on your demo page):

    – go to the form
    – fill nothing
    – click submit
    – error on first required element show up, do nothing
    – click submit again
    – now the required element is skipped and u get error on second element
    – if you always leave first element blank and fill only others then you are able to submit the form without required first element at the end

    Second bug is for displaying error message on blank email field. When you hit submit, you get the error message, but if you hit it again, error message is shown only for a very small time and then disappears. This not happens if you press submit with long click, so it might be some listener problem.

    Thank you for the fix.
    On.

    #2896

    Supporter
    Moderator

    Hi, could you give us your site, i’ll live check it. because form working ok on our server.
    Thanks.

    #2897

    ondrej
    Participant

    Unknow

    Hi,
    I will send you my site in private post but I have same behaviour on your site here:

    http://demo.cththemes.com/imevent/

    Just scroll to the form and hit REGISTER NOW several times. You will see validation is skipping between name and email. Tried Chrome and Firefox, both the same.
    On.

    #2898

    ondrej
    Participant

    Unknow
    This reply has been marked as private.
    #2899

    Supporter
    Moderator

    if you say register form bug on my site, so it not a bug, because i intention to do so. 🙂

    #2923

    ondrej
    Participant

    Unknow

    OK then 🙂 Not a bug, lets call it a feature. Do you by any chance plan to upgrade this feature? 😉

    #2924

    Supporter
    Moderator

    feature?sr but i dont undestand 🙂 , you can tell me more?

    #2925

    ondrej
    Participant

    Unknow

    You say it is intention (so a feature), but I ask if it possible to allow people to use forms in IM Event templates properly with working validation.

    #2926

    Supporter
    Moderator

    you want to edit validation again? you can tell me more what do you want, i’ll custom for you if it small custom :). sr but my english not good.

    #2927

    ondrej
    Participant

    Unknow

    I described the problem with validation above,if you want, I can send a picture.

    #2928

    Supporter
    Moderator

    oh, please send me a picture.

    #2929

    ondrej
    Participant

    Unknow

    Ok, here is some beautiful drawing, hope you understand now.

    Attachments:
    You must be logged in to view attached files.
    #2931

    Supporter
    Moderator

    Ah, i knew but now i ask you: what custom do you want? I will custom for you.

    #2932

    ondrej
    Participant

    Unknow

    If name is empty and you click the submit button than you must get the error that name is empty end focus on name field — every time when it is empty.

    #2933

    Supporter
    Moderator

    i can not login to your site to custom for you, please give me your admin panel account.
    Thanks

    #2955

    ondrej
    Participant

    Unknow
    This reply has been marked as private.
    #2993

    ondrej
    Participant

    Unknow

    Well, I found it, css with scroll-y issue…

    #3008

    Supporter
    Moderator

    i can not access to ftp account, please give me your adminpanel account.
    Thanks

    #3034

    ondrej
    Participant

    Unknow

    Hello,
    no need. I already fixed it on my site. Issue with mobile menu is related to scroll y. Issue with validation is related to changing value of input depending on time of button click (ex. the value can be “Name and Surname”, but also “Name an” or just “Nam”, etc… depending on time of the click. Than of course validation on fixed string is not working well. I have changed it to substr validation for first 3 letters only… Thank you anyway.

    #3046

    Supporter
    Moderator

    Oh, thanks 🙂

Viewing 20 posts - 1 through 20 (of 20 total)

You must be logged in to reply to this topic.