Getting Erros with Imported Demo Data Content

Home Forums WordPress Theme Springbook – Responsive WordPress Blog Travel Photography Theme Getting Erros with Imported Demo Data Content

This topic contains 3 replies, has 2 voices, and was last updated by  CTHthemes 11 months, 2 weeks ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #15409

    Matt
    Participant

    Support Expired

    Hello,

    I just bought this theme for my new website, but I’m getting errors when trying to use the Imported Demo Data (the one which gives all the theme examples).

    – I just made a clean install of wordpress 4.8.1
    – Installed springbook theme
    . Installed required plugins
    – Imported Full Demo Data content
    – Then go to Appearence -> Menu option and get all the errors shown in the image.

    Then I was checking them main page and i noticed that

    Home page -> Backgroud Video + Textslider and also
    Home page -> Slideshow

    Don’t work, they don’t have a url link attached, also the same warningS, which were displayed in Appearence -> Menu, are displayed here too.

    Also in all Home pages there are some unwanted widgets displayed in bad format: ‘Recent Post’, ‘Recent Comments’, ‘Archives’, etc.

    I don’t know if I skipped one configuration that needs to be done, or if this is a bug indeed.

    I just started using this theme and some guidance with this is going to be very helpful.

    Attachments:
    You must be logged in to view attached files.
    #15414

    CTHthemes
    Keymaster

    Hi, please try reinstall WordPress core and check if there is any unneeded plugin installed.
    About the widget issues please remove widgets from Categories Nav area

    #15425

    Matt
    Participant

    Support Expired

    Removing widgets from Categories Nav fixed the issue with bad format.

    About the other issue with import, I just made 2 more wp clean intalls and got the same result, same steps:

    – Installed springbook theme
    . Installed required plugins
    – Imported Full Demo Data content
    – Then go to Appearence -> Menu option and get all the errors shown in the image.

    But there is something curious about this case, this problem happens when importing the Demo Content with option ‘Appereance -> Import demo data’.

    Because I made a 4th clean install and then tried the 2nd way of importing demo data described in documentation, which is via ‘Tools -> Import’ and then upload the file ‘springbook.wordpress… xml’.

    Using that way, I got no errors and menu was working fine.
    Then, in order to get all demo content media files (because importing via xml didn’t bring all media) I decided to import all ‘Demo content’ using the ‘Appearence -> Import demo data’ option and I got the rest of media files and no errors were also displayed on Menu options. (Well there was two menu generated now, one from ‘Tools -> Import’ and the other ‘Appearence -> Import demo data’ but i just needed to delete the options repeated).

    So after that I realized that importing using ‘Appearence -> Import demo data’ doesn’t work as expected, you also need to import the XML file in order to remove the errors.

    I made a 5th attempt following this steps in order to make it work:

    – Installed wordpress
    – Installed springbook theme
    – Installed required plugins
    – Import Full Demo Data content via Appearence -> Import Demo Data
    – Import XML via Tools -> Import
    – Go to Menu (errors/warnings are not displayed anymore), Remove repeted options and save it.
    – And now in web all options work as expected.

    Is that the correct way? Because importing only via ‘Appearence -> Import Demo Data’ won’t work (at least it dind’t work for me).

    • This reply was modified 11 months, 2 weeks ago by  Matt.
    • This reply was modified 11 months, 2 weeks ago by  Matt.
    #15437

    CTHthemes
    Keymaster

    Ok, send me your wp-admin + ftp accounts to check.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.