New image files not uploading to library

This topic contains 6 replies, has 2 voices, and was last updated by  CTHthemes 3 months, 3 weeks ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #15539

    platypidesigns
    Participant

    Supported

    Hi there

    The website recently went live. So the URL path changed from :

    http://www.tractionteambuilding.com.au/pddemo

    to

    http://www.tractionteambuilding.com.au

    I moved the site from the subdirectory to the root directly. I updated the URLs through the database as well as through Velvet Blues plugin which helps replace one URL for another. I manually updated links on buttons and such and when someone visits the site it looks ok.

    I went to clean up the files on the server through FTP and tried to delete the “pddemo” folder and it deletes but then comes back. It doesn’t have all the files of a full WordPress installation but the path of folders is:
    /public_html/pddemo/wp-content/uploads/2017/09

    When I log into WordPress, I tried to upload an image to the Library and I can’t seem to get any image preview to come up. It just gives a grey box. I went to check the server (path: /public_html/wp-content/uploads/2017/09) and the image isn’t there. SEe screen shot live.jpg.

    When I check the pddemo path (/public_html/pddemo/wp-content/uploads/2017/09) the image has uploaded there.

    So I’m thinking that somewhere there is a miscommunication. I looked around to see if I could find information on this and I think it might be with an .htaccess file but I’m not sure. This is what I have for the htaccess file.

    =====================================

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # BEGIN WordPress

    # END WordPress
    ================================

    I will include the login to my account in a reply to this post so I can make it private.

    Thanks
    tanya

    Attachments:
    You must be logged in to view attached files.
    #15542

    platypidesigns
    Participant

    Supported
    This reply has been marked as private.
    #15568

    CTHthemes
    Keymaster

    Hi, please make sure that \wp-content/uploads/ folder and its children are writable.
    You can change their permission to 755 or 777;

    #15697

    platypidesigns
    Participant

    Supported

    Hi there,

    The permissions were already set to 755 and apply to the child folders.

    My issue is that somewhere in my WordPress switch from the subfolder “pddemo” the root directory the library path for uploads into WordPress did not change from

    /public_html/pddemo/wp-content/uploads/

    to

    /public_html/wp-content/uploads/

    The library uploads all the images to the pddemo folder which is no longer the current folder.

    Thanks,
    Tanya

    Attachments:
    You must be logged in to view attached files.
    #15715

    CTHthemes
    Keymaster

    You can try this .htaccess content:

    
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /pddemo/
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /pddemo/index.php [L]
    </IfModule>
    
    # END WordPress
    

    For later moving the development site you can use Duplicator plugin.

    #16143

    platypidesigns
    Participant

    Supported
    This reply has been marked as private.
    #16158

    CTHthemes
    Keymaster

    Hi, please correct the upload folder path here: http://prntscr.com/gq6ctk

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.